Ticket #94 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Catastrophic failure when connecting.

Reported by: mm.5p4mbox@gmail.com Owned by: alamaison
Priority: critical (affects core workflow) Milestone:
Component: authentication Version: 0.4.4
Keywords: Cc:

Description

I created SFTP connection to my local server.
When I double click the icon of newly created SFTP Connection I get error dialog with following text:

An error occurred while trying to access the directory:
Catastrophic failure

I'm using Windows 7 x64 SP1.

Change History

comment:1 Changed 9 years ago by alamaison

Does the 'Details' section of the error dialogue say anything else? Unfortunately, 'catastrophic failure' just means 'some failure happened'. It's the least specific type of error making it hard to diagnose.

One important thing: have you restarted the computer since installing? Sometimes the Swish components don't take properly until after restart.

If none of that works, can you give me more detail: what kind of server are you connecting to? OpenSSH? is it set up for password/keyboard-interactive/pubkey authentication? Are you sure the starting directory you set up really exists? What port number are you trying to connect to?

comment:2 Changed 9 years ago by martinsm

What Details section? Error dialog contains exactly text I pasted above. Only those two lines.

I tried restarting computer - no change. Same error dialog.

I'm connecting to FreeBSD 7.3 machine running OpenSSH 5.2. It's using custom port - 60022. I have no trouble logging into there with putty. Starting directory is entered correctly. I tried even with root / directory.

I've tried with different host - it's running ArchLinux? zwith OpenSSH 5.6 also on 60022 port. Same error message.

Both machines are using password authentication.

comment:3 Changed 9 years ago by alamaison

Apologies, it's been a long time since I ran v0.4.4 myself and I forgot that detailed errors messages weren't included in that release. I hope to make a new release this week and I suggest you wait for that. At the very least it should give us more error information to work with, though I have a feeling it will fix your problem.

At a guess, you're hitting an issue we fixed recently where some locales (e.g. USA) couldn't use port numbers above 999.

comment:4 Changed 9 years ago by martinsm

Indeed - that was the error, using port 60022. I switched to 622 and everything worked with both connections.

One small question - is it possible to show extension of files that Swish lists?

comment:5 Changed 9 years ago by alamaison

I've just made a new release, v0.4.5. Please try it and let me know if it fixes the problem.

comment:6 Changed 9 years ago by martinsm

With 0.4.5 release I can not connect to both 622 and 60022 ports.
Error dialog has following text for both ports:

[Window Title]
Swish

[Main Instruction]
Unable to access the directory

[Content]
You might not have permission.

[^] Hide details  [OK]

[Expanded Information]
Interface not registered

This happend when I double click on connection icon, even before asking password.
I have verified multiple times, that username is correct, and directory is entered correctly. I have tried restarting computer - no success, same error message.

comment:7 Changed 9 years ago by martinsm

  • Status changed from new to closed
  • Resolution set to fixed

Ok, after reading ticket #99, and doing regsvr32 provider-com_dll.dll and regsvr32 interfaces_dll.dll connection started to work.

I can connect successfully on 622 and 60022 port.

comment:8 Changed 9 years ago by alamaison

Oh dear. You are having the same problem as #99. I even saw it on one of my own computers but now can't reproduce it. Something is wrong with the installer.

I'll leave this ticket closed as you original problem is solved but #99 stays open of the moment - a workaround is not enough. I must fix the installer.

Note: See TracTickets for help on using tickets.