Ticket #90 (closed defect: fixed)

Opened 7 years ago

Last modified 3 years ago

Missing file extensions

Reported by: CHfish Owned by: alamaison
Priority: major (affects peripheral workflow) Milestone: 0.9.x Bug sprint
Component: remote folder Version: 0.4.4
Keywords: file extension Cc:

Description

For reason I can't tell Swish seems to hide file extension (not while renaming) although I disabled this in Windows.

Change History

comment:1 Changed 7 years ago by alamaison

  • Status changed from new to assigned
  • Component changed from authentication to remote folder

So it does. I'm not sure when this bug crept in there. It probably wont be fixed in time for the next release but should make the one after that. Thanks for reporting!

comment:2 Changed 6 years ago by alamaison

  • Milestone set to 0.6 Double-click access

comment:3 Changed 6 years ago by alamaison

  • Milestone changed from 0.6 Double-click access to 0.6.1 Bug sprint

comment:4 Changed 6 years ago by alamaison

  • Priority changed from minor to major

comment:5 follow-up: ↓ 6 Changed 6 years ago by anonymous

Any progress on this? I love the product, but for me, not being able to tell a file's extension is a show-stopper (i.e. "critical", not just "major").

comment:6 in reply to: ↑ 5 ; follow-ups: ↓ 7 ↓ 7 ↓ 17 Changed 6 years ago by alamaison

Replying to anonymous:

Any progress on this? I love the product, but for me, not being able to tell a file's extension is a show-stopper (i.e. "critical", not just "major").

I agree that it is annoying but there is a workaround, however unsatisfactory: press F2 and the extension will appear in the rename view. 'critical' is for bugs that present problems with Swish's basic functions on a continuous basis.

This bug isn't as easy to fix as it seems. It appears to be a bug in Explorer: regardless of whether the user has asked Explorer to show file extensions, Explorer still asks Swish for the no-extension version of the filename. We might have to try and sniff around Explorer's settings ourselves but this will take some work.

comment:7 in reply to: ↑ 6 Changed 6 years ago by anonymous

Replying to alamaison:

I agree that it is annoying but there is a workaround [...] It appears to be a bug in Explorer

Thank you very much for such a quick and detailed reply.

comment:8 Changed 6 years ago by alamaison

* Ticket #116 marked duplicate of this one *

comment:4 Changed 6 years ago by alamaison

* Ticket #130 marked duplicate of this one *

comment:3 Changed 6 years ago by alamaison

* Ticket #150 marked duplicate of this one *

comment:4 Changed 6 years ago by anonymous

+1 On this please

comment:5 follow-up: ↓ 6 Changed 5 years ago by alamaison

  • Milestone changed from 0.6.x Bug sprint to 0.7.x Bug sprint

comment:6 follow-ups: ↓ 7 ↓ 7 ↓ 17 Changed 5 years ago by anonymous

+1 on this - running 0.7.2 under Windows XP Pro x64, and still hiding file extensions. Hugely annoying.

comment:7 in reply to: ↑ 6 Changed 5 years ago by alamaison

Replying to anonymous:

Hugely annoying.

Agreed. Unfortunately still no idea how to fix it. If anyone knows how to find whether the user has asked Explorer to show file extensions, please make yourself heard.

I'm considering forcing extensions to be visible always. Would this annoy just as many people as having them hidden?

comment:8 Changed 5 years ago by anonymous

I would venture a guess that the demographic using Swish would almost unanimously be fine with extensions forced on. What is the use case for not showing extensions anyway? I never understood why that defaulted to off.

comment:9 Changed 5 years ago by Chaot_s


Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion?\Explorer\Advanced]
"HideFileExt?"=dword:00000000
"Hidden"=dword:00000001


Show / hide files is a profile based setting and as such a specific key in the users profile. To check the global machien defaults, see the default key's located in:
[HKLM\software\microsoft\windows\current version\explorer\advanced\folder\hidden]
and:
[HKLM\software\microsoft\windows\current version\explorer\advanced\folder\hidefileext]

Greets,
Chaot_s

comment:10 Changed 4 years ago by sam@bsharp.org

YES, please force extensions on if you can't determine the user prefs from the registry and make it work with Windows Explorer. It's a serious problem for me, because I often have two files with the same root name, different extension: anyone working with Java, for example, might have SomeThing?.java and SomeThing?.class in the same directory. They both read as SomeThing? in Swish/Explorer?. In my case there's a third SomeThing?.java~ from Emacs. (Fortunately, detailed view shows the .java~ file as type JAVA~, which is silly, but helpful in this case.)

comment:11 Changed 4 years ago by alamaison

In [1bb5eb6eb38b246a3adbae1a8868f40d504cb808/swish]:

Fix showing/hiding file extensions.

We were misunderstanding the SHGDN flags to GetDisplayNameOf?. We were assuming Explorer would set the SHGDN_FORPARSING flag if the user settings meant they wanted to see the file extension. But Explorer doesn't tell us whether the user wants extensions or not. We have to work that out for ourselves. The FORPARSING flag just *forces* extensions on in case the system needs them to parse them. The result for us was that we kept returning the name without the file extension because that was what we thought we were being asked for.

This change makes Swish decides whether to show extensions based on the settings in the registry. Thanks to Chaot_s for pointing us to the registry keys.

Addresses #90.

comment:12 Changed 4 years ago by alamaison

  • Status changed from assigned to closed
  • Resolution set to fixed

In [31b453c85ad0e9c83bc300e6c7562a1e7489941f/swish]:

Only hide extensions of known file types.

The previous change was hiding the extension of all file, if the user had "Hide extensions for known file types" set.

This change looks up each file's type in the registry to decide whether to show the extension based on the presence of the AlwaysShowExt? value. The "Unknown" file type includes that value, so this change fixes the problem and also takes care of other file types that should always show their extension regardless of user setting.

Closes #90.

comment:13 Changed 4 years ago by cdogg

This is still an issue, I've tried all the way down to version .4.6. Any ideas??

comment:14 Changed 4 years ago by alamaison

The issue has been fixed in commit [31b453c85ad0e9c83bc300e6c7562a1e7489941f/swish] and will appear in the next release.

comment:15 Changed 4 years ago by cdogg

I eagerly await :)

comment:16 Changed 4 years ago by alamaison

* Ticket #235 marked duplicate of this one *

comment:17 in reply to: ↑ 6 Changed 4 years ago by derek@colley.cc

I just upgraded to latest and this is still a problem

comment:18 Changed 4 years ago by khopkins

Problem still exists in 0.7.4.

comment:19 Changed 3 years ago by anonymous

3 yr old problem, still a problem. I just tried Swish out, but I guess it's time to move on.

Note: See TracTickets for help on using tickets.