Ticket #48 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Connection form allocates 100MB memory

Reported by: alamaison Owned by: alamaison
Priority: blocker (cannot release, e.g. data loss) Milestone: 0.5 Failure and UI cleanup
Component: host management Version: 0.3.2.0
Keywords: Cc:

Description (last modified by alamaison) (diff)

The GDI handles *don't* increase massively though.

Change History

comment:1 Changed 9 years ago by alamaison

  • Description modified (diff)
  • Summary changed from Connection form allocated 100MB memory on WIndows 2000 to Connection form allocated 100MB memory on Windows 2000

comment:2 Changed 9 years ago by alamaison

  • Status changed from new to accepted

comment:3 Changed 9 years ago by alamaison

  • Summary changed from Connection form allocated 100MB memory on Windows 2000 to Connection form allocates 100MB memory

This happens regardless of OS.

May be caused by all the boost:signal members which exist for every window. Still, 100MB seems far too much for a form with 20 controls.

comment:4 Changed 9 years ago by alamaison

  • Priority changed from critical to blocker

comment:5 Changed 9 years ago by alamaison

  • Status changed from accepted to closed
  • Resolution set to fixed

A very simple fix! :)

We were incrementing the result of a function that already performed the increment internally. This made the allocated buffer size increase exponentially to the number of controls on the form. Ouch.

Note: See TracTickets for help on using tickets.