Ticket #373 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Does not work on 8.1 x64 for me

Reported by: 2e20f13c@opayq.com Owned by: alamaison
Priority: major (affects peripheral workflow) Milestone:
Component: libssh2 Version:
Keywords: Cc:

Description

Windows 8.1 x64
Not sure what specs are relevant.
Private key has a passcode, but that should be irrelevant, as it's decoded into putty agent.

I have a valid puttygen private key, verified by ssh'ing into the box, used agent just fine, ssh'ed without issue.

Added sftp host, does not work. Path is non-traditional (/home/hd5/myoung34 - grabbed via 'pwd'), not sure if helpful.

Also, settings for SFTP are fine in general, WinSCP works without issue. Error screenshot and general 'about' ss are also attached.

Attachments

Capture.PNG Download (76.2 KB) - added by anonymous 5 years ago.
error screenshot
Capture2.PNG Download (24.7 KB) - added by anonymous 5 years ago.
general settings ss

Change History

Changed 5 years ago by anonymous

error screenshot

Changed 5 years ago by anonymous

general settings ss

comment:1 Changed 5 years ago by anonymous

I will add that my system is heavily built around Cygwin. If it's trying to do anything with files in my Windows home directory (C:\Users\myoung), some might be symbolic links, which don't play well with some windows applications. However, files in my ~/.ssh/ are not sym linked, but might be modified for permissions, or have non-windows line endings.

comment:2 Changed 5 years ago by alamaison

Can you confirm which version of Swish you are using? The error is caused by your known_hosts file having a key in a format that Swish doesn't recognise. I thought we had fixed this but perhaps the fix isn't in your version of Swish.

comment:3 Changed 5 years ago by anonymous

0.8.2, the problem persisted on the prior version as well.

comment:4 Changed 5 years ago by anonymous

I honestly have no idea how to explain what just happened.
After posting that, I tried again. No reboots, no changes. Puttyagent not running.
When I clicked the host, it notified me that the fingerprint changed, and asked for my password to the server instead of immediately failing out, and connected. I guess close this as resolved, and I have no idea how to explain what just happened.

comment:5 Changed 5 years ago by alamaison

  • Status changed from new to closed
  • Resolution set to fixed

Two possibilities:

  • You didn't reboot between upgrading to 0.8.2 and using it. That might have left the previous version loaded by explorer.exe so really you were still using the old, broken code. Rebooting isn't technically required when upgrading Swish, but sometimes the installer fails to restart explorer.exe properly.
  • The bug in Swish still exists. It rewrote your known_hosts file but ommitted the key it didn't recognise.

I hope its the first one because the second would be quite unexpected. If this re-occurs, please reopen this issue.

Note: See TracTickets for help on using tickets.