Ticket #263 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

Colon in folder name cause NO SUCH FILE

Reported by: anonymous Owned by: alamaison
Priority: major (affects peripheral workflow) Milestone:
Component: undefined Version:
Keywords: Cc:

Description

When accessing a remote folder with a name such as "Aa:Be", only "Be" is shown as its name in Explorer. Attempting to open shows the error

[Expanded Information]
Failed opening remote file: FX_NO_SUCH_FILE

Bug report information: C:\Users\awl03\Documents\Visual Studio 2005\Projects\swish\ssh/detail/libssh2/sftp.hpp(127): Throw in function struct _LIBSSH2_SFTP_HANDLE *cdecl ssh::detail::libssh2::sftp::open(struct _LIBSSH2_SESSION *,struct _LIBSSH2_SFTP *,const char *,unsigned int,unsigned long,long,int)
Dynamic exception type: class boost::exception_detail::clone_impl<struct boost::exception_detail::error_info_injector<class boost::system::system_error> >
std::exception::what: Failed opening remote file: FX_NO_SUCH_FILE
[struct boost::errinfo_api_function_ *
ptr64] = libssh2_sftp_open_ex
[struct boost::errinfo_file_name_ * ptr64] = /homefolder/Be

Folder name was verified using FileZilla? (which *does* show the full name).
Attempts to change the Explorer view to this folder using the navigation bar failed, as it defaulted back to its own not-secure FTP.

Attachments

colon_path.png Download (91.5 KB) - added by alamaison 4 years ago.
Folder open despite colons in path

Change History

Changed 4 years ago by alamaison

Folder open despite colons in path

comment:1 Changed 4 years ago by alamaison

What version of Windows and what version of Swish are you using?

I am unable to reproduce the problem on Windows 7 with Swish 0.8.0:
Folder open despite colons in path

comment:2 Changed 4 years ago by alamaison

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.