Ticket #221 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Crash on upload on Windows 8

Reported by: anonymous@dhwx.de Owned by: alamaison
Priority: critical (affects core workflow) Milestone: 0.9.x Bug sprint
Component: remote folder Version: 0.7.2
Keywords: upload bug crash Cc: anonymous@dhwx.de

Description

Everytime I try to upload a file, no matter how big or what type of (tried big 7zip- File, one small headerbackupfile from Truecrypt and a simple txt) it crashes. Downloading btw works fine...
But it's good work! Keep going on!

Change History

comment:1 Changed 7 years ago by alamaison

In what way does it crash? Please give as much detail as you can.

comment:2 Changed 7 years ago by anonymous@dhwx.de

I am sorry, I forgot. :)
I use Win8 64-bit and open every explorer window in a new Process. Adding and then connecting to my linux server is no problem. Now, when I drag&drop the files mentioned before (or copy&paste it, no matter) this explorer window does not respond. After a short moment and a double click it simply closes. That's all.
Pageant isn't affected.The integration in a new explorer window neither. I can reconnect without problems. The Server should't be the problem too. At least it worked fine when I connected via commandline SSH, git and web.

comment:3 Changed 7 years ago by alamaison

  • Owner changed from dhwx to alamaison
  • Priority changed from blocker (cannot release, e.g. data loss) to critical (affects core workflow)
  • Status changed from new to accepted

Do you know if the same problem happens with other versions of Windows? Swish hasn't been tested with Windows 8 yet.

comment:4 follow-up: ↓ 5 Changed 7 years ago by anonymous@dhwx.de

If I wouldn't have to do so much work for school I would check it for you as I have Win7 installed in dualboot. If you can wait I'll check it on thursday afternoon (and write the results here).
No, I don't know if this happens with other Windowsversions.
If you use the SYSTEM32.dll file (I don't know enough about coding to determine this), the issue may be that it was renamed to system32.dll in Win8. In my experience some progs are casesensitive there.

comment:5 in reply to: ↑ 4 Changed 7 years ago by alamaison

Replying to anonymous@…:

If I wouldn't have to do so much work for school I would check it for you as I have Win7 installed in dualboot. If you can wait I'll check it on thursday afternoon (and write the results here).

That's fine. No rush. I won't have time to get into this for a couple of weeks anyway.

No, I don't know if this happens with other Windowsversions.
If you use the SYSTEM32.dll file (I don't know enough about coding to determine this), the issue may be that it was renamed to system32.dll in Win8. In my experience some progs are casesensitive there.

Good to know. Though I'd be surprised if that were the cause of this problem.

comment:6 follow-up: ↓ 7 Changed 7 years ago by anonymous

I can confirm that this happens, too. All it does is make a zero-length file on the remote computer, then all my Explorer windows close.

comment:7 in reply to: ↑ 6 Changed 7 years ago by alamaison

Replying to anonymous:

I can confirm that this happens, too.

Is this also on Windows 8?

All it does is make a zero-length file on the remote computer, then all my Explorer windows close.

That it creates a zero-length file is a very useful bit of information to help track down the cause. Thanks.

comment:8 Changed 7 years ago by alamaison

  • Summary changed from Crash on upload to Crash on upload on Windows 8

comment:9 Changed 7 years ago by VBAssassin

Hello,

I can also confirm this. To replicate the problem:

  1. Create a .txt file with some garbage text in it
  2. Add an SFTP connection to a Linux Server (in my case Ubuntu), root account with password
  3. Accept certificate
  4. Open the SFTP folder
  5. Drag and drop the .txt file into a folder on the server
  6. It freezes and the window closes

To help you debug, here is the system info from dxdiag:


System Information


Time of this report: 3/10/2013, 14:05:28
Machine name: MY-LAPTOP
Operating System: Windows 8 64-bit (6.2, Build 9200) (9200.win8_gdr.120926-1855)
Language: English (Regional Setting: English)
BIOS: 6.30
Processor: Intel(R) Pentium(R) CPU B960 @ 2.20GHz (2 CPUs), ~2.2GHz
Memory: 8192MB RAM
Available OS Memory: 8074MB RAM
Page File: 1912MB used, 10768MB available
Windows Dir: C:\windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag? Version: 6.02.9200.16384 64bit Unicode

The version of Swish I'm using is: 0.72 (28th December 2012)

Kind regards,
Scott -  http://www.coderprofile.com/coder/VBAssassin

comment:10 Changed 7 years ago by Alexander Lamaison <alexander.lamaison@gmail.com>

  • Status changed from accepted to closed
  • Resolution set to fixed

In [6445c3fabf5737227f4dcfbac584c9cc098951ea/swish]:

Fix crash in Windows 8 drag-and-drop.

Windows 8 file-system IStreams have a bug where a call to Stat() doesn't set the pwcsName field even though STATFLAG_DEFAULT is passed. This NULL pointer that is never supposed to be null caused Explorer to crash when we returned it as a string. We never even used the string!

This change stops the code requesting the name so it just uses the file size, avoinding the problem altogether.

Fixes #221.

Note: See TracTickets for help on using tickets.