Ticket #219 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Connection drops very quickly

Reported by: seven@phorus.co.uk Owned by: alamaison
Priority: major (affects peripheral workflow) Milestone:
Component: backend Version: 0.7.0
Keywords: Cc:

Description

Hi,

I am finding Swish a very valuable add-on as I work from home a lot and connect to my work SFTP server. It is far more productive than Filezilla and is working almost perfectly with Q-Dir multi-pane file manager.
The problem I have is that the connection to the remote host seems to drop very quickly - less than a minute after a file transfer. Filezilla stays connected much longer, (30 min or more) so I don't thing the remote machine is timing out the connection.
Is this a bug, or is it intentional?
If it is intentionally kept short at the moment, then it would be very valuable for the user to be able to adjust the connection time in some way in future versions.

Many thanks,

Peter

Change History

comment:1 follow-up: ↓ 2 Changed 7 years ago by alamaison

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from host management to backend

It's a known bug in Swish. You may be able to work around it for the moment by adjusting the ClientAliveInterval? on the server. See #193 for more.

* Marked duplicate of #193 *

comment:2 in reply to: ↑ 1 Changed 7 years ago by seven@phorus.co.uk

Replying to alamaison:

It's a known bug in Swish. You may be able to work around it for the moment by adjusting the ClientAliveInterval? on the server. See #193 for more.

* Marked duplicate of #193 *

Thank you - I've read your reply and #193.

Regrettably I can't change anything on the server side as that is a university resource and out of my control.
I look forward to a fix in Swish and appreciate your work towards a resolution. Meantime will continue to use Swish in spite of this issue as it is such an effective and productive application.

All the best,

Peter

Note: See TracTickets for help on using tickets.