Ticket #214 (closed enhancement: duplicate)

Opened 7 years ago

Last modified 7 years ago

Option to save passwords

Reported by: ITsupporter Owned by: alamaison
Priority: minor (e.g. uncommon, cosmetic, has workaround) Milestone: 0.90 Beta 1
Component: authentication Version: 0.7.0
Keywords: password Cc:

Description

It would be really nice to the option of saving the login passwords (in Windows?). It is a bit annoying to login manually after every restart. Is this possible?

Change History

comment:1 Changed 7 years ago by alamaison

  • Status changed from new to closed
  • Resolution set to duplicate

We intentionally didn't add this feature to Swish as SSH has a better way to achieve the same thing built in to the protocol. It's called public key authentication and all you have to do is add your key to the Pageant key agent which is included with Swish.

If you really want the least secure option of storing your unencrypted key on disk (a key is basically a big password) for a prompt-free login, follow these instructions and enter a blank password when generating the key. Then add a shortcut to your key file to your Windows startup folder. This will load it into the agent when you log in.

* Marked duplicate of #134 *

Note: See TracTickets for help on using tickets.