Ticket #197 (closed defect: duplicate)

Opened 8 years ago

Last modified 8 years ago

Greek characters in file & directory names show up as gibberish

Reported by: klonos@gmail.com Owned by: alamaison
Priority: major (affects peripheral workflow) Milestone:
Component: i18n Version: 0.7.0
Keywords: Cc:

Description

I have the same issue when using the competitor software ExpanDrive?. Files and directories on remote shares with unicode (non-latin) names show up as gibberish. When I mount these shares directly in a linux host through the mount command, I need to specify the iocharset and codepage options. Like so:

mount -t cifs //server_name_or_ip/share -o username=someuser,password=somepass,iocharset=iso8859-7,codepage=737 /mnt/somedir

...mind you, that using iocharset=utf8 doesn't work.

PS: The remote shares are on a Win7 x64 Greek PC - I don't know if this is a problem specific to Windows shares or Greek locale being used in these Windows shares.

Change History

comment:1 Changed 8 years ago by alamaison

  • Status changed from new to closed
  • Resolution set to duplicate

You've half answered your own question :P The filenames on your remote share are not in unicode, they are in iso8859-7, a Greek, non-unicode codepage. Hence why you have to specify it explicitly in your mount command.

Swish currently assumes all filenames are Unicode. It's a known 'bug' (missing feature). Eventually we hope to autodetect the filename encoding.

* Marked duplicate of #158 *

Note: See TracTickets for help on using tickets.