Ticket #155 (closed enhancement: duplicate)

Opened 8 years ago

Last modified 8 years ago

Remember password option

Reported by: isabelle.thibeault@sric.ca Owned by: thibeault
Priority: minor (e.g. uncommon, cosmetic, has workaround) Milestone: 2.0 Extra features
Component: authentication Version: 0.6.0
Keywords: Cc:

Description

Hi,

I want to know if it could be possible to add remember password option.

Thanks.

Change History

comment:1 Changed 8 years ago by alamaison

  • Status changed from new to closed
  • Resolution set to duplicate

We won't add password saving to Swish for two main reasons:

  • We will be adding public-key authentication to Swish which is a better way to achieve the same result
  • The authentication method used by many servers nowadays (keyboard-interactive) makes it impossible to reliably respond with a saved password

* Marked duplicate of #134 *

comment:3 follow-up: ↓ 4 Changed 8 years ago by michael

ups please delete the mailadress or the whole last comment. my mailaddress is not to be published. cheers, michael

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 8 years ago by alamaison

Replying to michael:

i would very much appreciate the password saving option.
i have to type it in each time :-(

When you say "each time", what do you mean? Each time you log back in to Windows? Because the connection should remain open as long as you don't log out of Windows so you wouldn't need to reenter the password.

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 8 years ago by michael

Replying to alamaison:

i have to type it in each time :-(

When you say "each time", what do you mean? Each time you log back in to Windows? Because the connection should remain open as long as you don't log out of Windows so you wouldn't need to reenter the password.

yes. "each time" refers to logins to windows. not so with nautilus on linux. there i can choose whether the pw should be remembered. makes live quite easyer. especially if you have 5 computers which make the connections and the password is complicated.

comment:6 in reply to: ↑ 5 Changed 8 years ago by alamaison

Replying to michael:

Replying to alamaison:

i have to type it in each time :-(

When you say "each time", what do you mean? Each time you log back in to Windows? Because the connection should remain open as long as you don't log out of Windows so you wouldn't need to reenter the password.

yes. "each time" refers to logins to windows. not so with nautilus on linux. there i can choose whether the pw should be remembered. makes live quite easyer. especially if you have 5 computers which make the connections and the password is complicated.

We plan to implement public-key authentication soon which is the 'right' way to do passwordless login for SSH. I'm not convinced the Nautilus SSH behaviour is something we want to emulate. Notably, the OpenSSH command-line client doesn't offer a way to save passwords either and is probably a better reference than Nautilus.

Note: See TracTickets for help on using tickets.