Ticket #148 (closed enhancement: duplicate)

Opened 6 years ago

Last modified 5 years ago

Logout for each connection

Reported by: andreas.in.hk@googlemail.com Owned by: alamaison
Priority: minor (e.g. uncommon, cosmetic, has workaround) Milestone: 0.7 Public-key authentication
Component: authentication Version: 0.6.0
Keywords: logout Cc:

Description

Hi, thanks for providing the swish software, its very nice and good to use. But instantely I've missing the function to logout after I've finished my task and secondly I've missed the option to edit already created sftp-connections (e.g. change the default directory).

Change History

comment:1 in reply to: ↑ description ; follow-up: ↓ 2 Changed 6 years ago by alamaison

  • Milestone 0.90 Beta 1 deleted

Please only file one issue per bug report. Otherwise it makes it impossible to keep track of them.

Replying to andreas.in.hk@…:

Hi, thanks for providing the swish software, its very nice and good to use. But instantely I've missing the function to logout after I've finished my task

I'm curious why you would want to log out? We leave the connections open until you log out of Windows so that you don't have to reenter your password so often. Is the some scenario I'm not aware of?

secondly I've missed the option to edit already created sftp-connections (e.g. change the default directory).

Already filed: #37.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 6 years ago by andreas.in.hk@googlemail.com

Replying to alamaison:

Please only file one issue per bug report. Otherwise it makes it impossible to keep track of them.

Replying to andreas.in.hk@…:

Hi, thanks for providing the swish software, its very nice and good to use. But instantely I've missing the function to logout after I've finished my task

I'm curious why you would want to log out? We leave the connections open until you log out of Windows so that you don't have to reenter your password so often. Is the some scenario I'm not aware of?

To prevent logout of user session. Here I have some siftware that runs some days continuosly (computing/measuring)
so logging off the windows user is not suitable. But for elevated security (e.g. others may go to the comsole) I would like to
close the connection to the ssh-server after I've finished my work.

secondly I've missed the option to edit already created sftp-connections (e.g. change the default directory).

Already filed: #37.

comment:3 in reply to: ↑ 2 Changed 6 years ago by alamaison

  • Keywords logout added; logout, edit removed
  • Priority changed from major (affects peripheral workflow) to minor (e.g. uncommon, cosmetic)
  • Summary changed from Logout and Edit of settings for each connection to Logout for each connection
  • Status changed from new to accepted
  • Milestone set to 0.20 Public-key authentication

Replying to andreas.in.hk@…:

Replying to alamaison:

I'm curious why you would want to log out? We leave the connections open until you log out of Windows so that you don't have to reenter your password so often. Is the some scenario I'm not aware of?

To prevent logout of user session. Here I have some siftware that runs some days continuosly (computing/measuring)
so logging off the windows user is not suitable. But for elevated security (e.g. others may go to the comsole) I would like to
close the connection to the ssh-server after I've finished my work.

Understood. It should be possible to add this to the operations on a host connection.

comment:4 Changed 6 years ago by alamaison

Note to developers: A complication is that you can connect to SFTP servers using a URL, not only via the folder of connections. One way to work around this would be to add any running connections to a 'Temporary' category in the host folder so that there is a UI artifact to logout from. Might also be nice to have a command that converts a temporary connection into a permanent one.

comment:5 Changed 5 years ago by alamaison

  • Status changed from accepted to closed
  • Resolution set to duplicate

* Marked duplicate of #85 *

Note: See TracTickets for help on using tickets.