Ticket #144 (closed defect: fixed)

Opened 9 years ago

Last modified 8 years ago

Unable to connect with swish; can connect with Core SFTP

Reported by: marshallabrams@comcast.net Owned by: alamaison
Priority: minor (e.g. uncommon, cosmetic, has workaround) Milestone:
Component: authentication Version:
Keywords: Cc:


I'm using the Core mini-sftp-server on my desktop. I'm also using the Core client on my laptop. I am able to open an sftp connection and transfer files usinga window like Norton commander. I tried to use swish with my laptop next to my desktop. I could see the connection open, I think the password was accepted because I mistyped the password and swish came back and asked me for the password again. But after I typed the correct password, I got an error message from swish "Unable to access the directory. You may not have permission." In Core, I don't specify any directory and it opens in \c:.

I tried again and this time my password was not accepted. I went back to Core and it worked fine. What do you suggest?

Change History

comment:1 Changed 9 years ago by htwiz2002@gmail.com

Same sort of issue. I can log in and see the initial working directory, but clicking on any item brings up three modal dialog boxes that say Unable to access the Directory. Nothing can be done here...

comment:2 Changed 9 years ago by alamaison

What path have you set in your Swish connection? Try / (a single forward-slash) and see what happens. SFTP paths follow the Unix convention of directories dived by / rooted with an inital /. So even if the CoreFTP server is set up to serve C:\, the path the client has to pass to access that is /.

comment:3 Changed 8 years ago by alamaison

Did the suggested workaround fix the problem?

comment:4 Changed 8 years ago by anonymous

Since moving on to windows 8, I haven't been able to install it properly. I have since had to just deal with it.

comment:5 Changed 8 years ago by alamaison

We've just made  a new release (v0.6.1) that fixes some bugs and (we hope) should install on Windows 8. Please give it a whirl and update this ticket with your progress.

comment:6 Changed 8 years ago by htwiz2002@gmail.com

Now that the version check is bypassed, the installer actually proceeds. However, even after a successful connection, the action of selecting one of the items populated results in an Out-of-memory exception (that happens twice). The exact "Detailed" message states that "Not enough storage is available to complete this operation."

comment:7 Changed 8 years ago by alamaison

We've fixed the Windows 8 bug in  v0.6.3. Can you reproduce your problem with this version?

comment:8 Changed 8 years ago by htwiz2002@gmail.com

The problem does appear resolved. Thanks! ;)

comment:9 Changed 8 years ago by alamaison

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.